summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpiotr2018-11-15 00:14:47 +0100
committerpiotr2018-11-15 00:14:47 +0100
commitd6894734629f205375c4ff6a9f444c1faf6c5cce (patch)
tree682e8c8bf80d63ab60ff74e13db3dacb6d772c54 /PKGBUILD
parentcc9a4ed1f3a68455d351155e9b68ac1661f3ba74 (diff)
downloadaur-d6894734629f205375c4ff6a9f444c1faf6c5cce.tar.gz
support for icons (1 per executor) with -I<component> argument
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec8700a8cbe1..d05e7f6332c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,34 @@
# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('psuinfo')
-pkgver=0.0.3
-pkgrel=2
-pkgdesc="A psutil-based command to display customizable system usage info in a single line, intended for Tint2 executors or CLI"
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="A psutil-based command to display customizable system info, intended for Tint2 or other panels"
arch=('x86_64')
url="https://github.com/nwg-piotr/psuinfo"
license=('GPL3')
depends=('python' 'python-psutil')
-source=(https://github.com/nwg-piotr/psuinfo/raw/master/psuinfo)
+source=("https://github.com/nwg-piotr/psuinfo/raw/master/psuinfo"
+ "https://github.com/nwg-piotr/psuinfo/raw/master/icons/cpu.svg"
+ "https://github.com/nwg-piotr/psuinfo/raw/master/icons/fan.svg"
+ "https://github.com/nwg-piotr/psuinfo/raw/master/icons/hdd.svg"
+ "https://github.com/nwg-piotr/psuinfo/raw/master/icons/mem.svg"
+ "https://github.com/nwg-piotr/psuinfo/raw/master/icons/swap.svg"
+ "https://github.com/nwg-piotr/psuinfo/raw/master/icons/temp.svg"
+ "https://github.com/nwg-piotr/psuinfo/raw/master/icons/up.svg")
-md5sums=('8dd1d0c548b7bdacf14f6bb2c8d20e5b')
+md5sums=('77d21a0f513ba659305d2312cd6390ab'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
package() {
install -D -m 755 psuinfo \
"$pkgdir"/usr/bin/psuinfo
+ install -D -t "$pkgdir/usr/share/$pkgname" *.svg
}