summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072023-11-11 23:33:06 +0100
committersL1pKn072023-11-11 23:33:06 +0100
commit9f0c8a74758f12583956504f9479cbeb9e2004eb (patch)
treebce64f237a138c74c2f8944d593a12c387ee0f44 /PKGBUILD
parente58710ba7f01859618a1549d5749cb6d256d097c (diff)
downloadaur-9f0c8a74758f12583956504f9479cbeb9e2004eb.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29969c5b195a..db6094128da9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,14 @@ arch=('any')
pkgdesc="PSV file trimmer, restoration, and validation utility (Python). (GIT version)"
url='https://github.com/kageurufu/psvtools'
license=('MIT')
-depends=('python-setuptools')
-makedepends=('git')
+makedepends=(
+ 'git'
+ 'python-setuptools'
+ 'python-installer'
+ 'python-wheel'
+ 'python-build'
+ 'python-pytest-runner'
+)
conflicts=('psvtools')
provides=('psvtools')
source=('git+https://github.com/kageurufu/psvtools.git')
@@ -19,9 +25,14 @@ pkgver() {
echo "$(git describe --long --tags | tr - .)"
}
+build() {
+ cd psvtools
+ python -m build --wheel --no-isolation
+}
+
package() {
cd psvtools
- python setup.py install --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}