summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew McGinn2017-03-26 14:54:53 -0400
committerMatthew McGinn2017-03-26 14:54:53 -0400
commit450399043f3510f0acdb788cd53fdff512843fc7 (patch)
tree17eb24f4374d9d5480fd7613c4c22d38372c7046 /PKGBUILD
parent009cc48c9126b8d6c1cacf3ce415899c00b0c4bc (diff)
downloadaur-450399043f3510f0acdb788cd53fdff512843fc7.tar.gz
fixing broken src refs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a95ea745776a..ca2b362f4fb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Matthew McGinn <mamcgi@gmail.com>
pkgname=ptpd-git
+_pkgname=ptpd
pkgrel=1
pkgver=235e9b4
pkgdesc="The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as defined by the relevant IEEE 1588 standard. PTP Version 2 implements IEEE-1588-2008. PTP was developed to provide very precise time coordination of LAN connected computers."
@@ -7,30 +8,31 @@ arch=('any')
url="https://github.com/ptpd/ptpd"
license=('BSD')
conflicts=('ptpd2')
-depends=('libpcap' 'net-snmp')
+depends=('libpcap')
+optdepends=('net-snmp')
provides=('ptpd2')
-source=("git+https://github.com/${pkgname}/${pkgname}")
+source=("git+https://github.com/${_pkgname}/${_pkgname}")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
git describe --always
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
autoreconf -vi
./configure --prefix=/usr --sbindir=/usr/bin
make
}
check() {
- cd "$pkgname"
+ cd "$_pkgname"
make -k check
}
package() {
- cd "$pkgname"
+ cd "$_pkgname"
make DESTDIR="$pkgdir/" install
install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/$pkgname/COPYRIGHT"
}