summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcarlwgeorge2016-01-13 22:13:03 -0600
committercarlwgeorge2016-01-13 22:13:03 -0600
commit7ddf34e586ac9a3280dc4f2d543a9c58c5439a35 (patch)
tree8c76e84c9b4a8e2748a68f3302547187702c6004 /PKGBUILD
parent1284cb0a4e4c0ecc60717027c2c3b855dcc7503b (diff)
downloadaur-7ddf34e586ac9a3280dc4f2d543a9c58c5439a35.tar.gz
new package?
I thought I was adding a new package, but it exists in git somehow, despite not showing up in an AUR search.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD74
1 files changed, 48 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eabfd382f368..1d48ec5218fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,59 @@
+# Maintainer: Carl George < arch at cgtx dot us >
# Contributor: Erik Johnson <palehose at gmail dot com>
-pkgbase=ptpython
-pkgname=("${pkgbase}" "${pkgbase}2")
-pkgver=0.8
-pkgrel=1
-pkgdesc="An advanced Python REPL, built on top of the prompt_toolkit library"
-arch=(any)
-url="https://pypi.python.org/pypi/${pkgbase}"
-license=('CUSTOM')
-source=("https://pypi.python.org/packages/source/p/${pkgbase}/${pkgbase}-${pkgver}.tar.gz")
-sha256sums=(342d966c6671f9cc57f7dc8eec2595411ad1cca0e3da25e0997f9812431cf4c0)
+pkgbase="ptpython"
+pkgname=("ptpython" "ptpython2")
+pkgver="0.28"
+pkgrel="1"
+pkgdesc="Python REPL build on top of prompt_toolkit"
+arch=("any")
+url="https://github.com/jonathanslenders/ptpython"
+license=("BSD")
+makedepends=(
+ "python-setuptools"
+ "python2-setuptools"
+)
+source=("https://pypi.python.org/packages/source/${pkgbase:0:1}/${pkgbase}/${pkgbase}-${pkgver}.tar.gz")
+sha256sums=('f4bc7c4b129925be316c60669b5c0a5cc97edc0fb381fd007aa0ecc81758ee1d')
prepare() {
- cp -a ${pkgbase}-${pkgver}{,-py2}
+ cp -a "${srcdir}/${pkgbase}-${pkgver}" "${srcdir}/${pkgbase}2-${pkgver}"
}
-package_ptpython() {
- depends=('python-prompt_toolkit' 'python-jedi>=0.8.1' 'python-docopt')
- makedepends=('python-setuptools')
- optdepends=('ipython: ptipython (ptpython iPython wrapper)')
+build() {
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py build
+ cd "${srcdir}/${pkgbase}2-${pkgver}"
+ python2 setup.py build
+}
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1
+package_ptpython() {
+ depends=(
+ "python-prompt_toolkit=0.57"
+ "python-jedi>=0.9.0"
+ "python-docopt"
+ )
+ optdepends=(
+ "ipython: ptipython (ptpython + ipython)"
+ )
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
package_ptpython2() {
- depends=('python2-prompt_toolkit' 'python2-jedi>=0.8.1' 'python2-docopt')
- makedepends=('python2-setuptools')
- optdepends=('ipython2: ptipython2 (ptpython iPython wrapper)')
-
- cd "${srcdir}/${pkgbase}-${pkgver}-py2"
- python2 setup.py install --root="$pkgdir" --optimize=1
- mv "${pkgdir}/usr/bin/ptpython"{,2}
- mv "${pkgdir}/usr/bin/ptipython"{,2}
+ depends=(
+ "python2-prompt_toolkit=0.57"
+ "python2-jedi>=0.9.0"
+ "python2-docopt"
+ )
+ optdepends=(
+ "ipython2: ptipython2 (ptpython2 + ipython2)"
+ )
+ cd "${srcdir}/${pkgbase}2-${pkgver}"
+ python2 setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgdir}/usr/bin"
+ mv ptpython{,2}
+ mv ptipython{,2}
}
-