summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2017-11-05 02:39:36 +0100
committerFabioLolix2017-11-05 02:39:36 +0100
commitbecb50b9c8bf64ce8f7a74a534c7f79e6df36858 (patch)
treea786b8dc4c5b54282daab5f74160b09f5238c3ec /PKGBUILD
downloadaur-becb50b9c8bf64ce8f7a74a534c7f79e6df36858.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b9f69489c04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+
+pkgname=ptxconf-git
+pkgver=r35.70d2e20
+pkgrel=2
+pkgdesc="Pen tablet and Touch screen Xinput Configuration tool (PTXConf). Configures touch/pen devices to work with extended desktops and multiple screens on Linux"
+arch=('i686' 'x86_64')
+url="https://github.com/wenhsinjen/ptxconf"
+license=('AGPL3')
+depends=('xorg-xinput' 'python2-libappindicator' 'python2' 'pygtk')
+makedepends=('git')
+provides=('ptxconf')
+conflicts=('ptxconf')
+source=("${pkgname}::git+https://github.com/wenhsinjen/ptxconf.git"
+ 'ptxconf.desktop')
+md5sums=('SKIP'
+ 'ea437e99722a1ce37f0893ddac76afe4')
+
+pkgver() {
+ cd ${pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ python2 setup.py install --root=${pkgdir}/ --optimize=1
+ mv ${pkgdir}/usr/bin/ptxconf.py ${pkgdir}/usr/bin/ptxconf
+ install -D ${srcdir}/ptxconf.desktop ${pkgdir}/usr/share/applications/ptxconf.desktop
+}