summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMorgenstern2024-03-17 15:58:26 +1300
committerMorgenstern2024-03-17 15:58:26 +1300
commita7d7412f874877e800ede96a8633820c628efbf5 (patch)
tree0c3df12763cd503cef6bf06c5d7b350f0d491f3e /PKGBUILD
parentbc75956f742e6882743b22af0517a3b941ead3f3 (diff)
downloadaur-a7d7412f874877e800ede96a8633820c628efbf5.tar.gz
Update to 2.3.0
Add python-distro and python-unidecode dependencies Use SPDX license identifier
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index caebf35c739f..e7eeca4c5384 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
pkgname=puddletag
-pkgver=2.2.0
-pkgrel=2
+pkgver=2.3.0
+pkgrel=1
pkgdesc='An audio tag editor for GNU/Linux'
url="https://docs.${pkgname}.net/"
-license=('GPL3')
+license=('GPL-3.0-or-later')
arch=('any')
depends=('python-configobj'
+ 'python-distro'
'python-mutagen'
'python-pyparsing'
'python-pyqt5'
+ 'python-unidecode'
'qt5-svg')
makedepends=('python-build'
'python-installer'
@@ -21,7 +23,7 @@ optdepends=('chromaprint: AcoustID support'
'python-lxml: additional tag sources'
'quodlibet: QuodLibet library support')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/puddletag/puddletag/archive/${pkgver}.tar.gz")
-sha512sums=('92c430f54b49d2f193ffc4168f35bbadb069ca9b41b28250ee1c6dcb84853def20865d6df52940eebff8c5b812c0c8ab6b8971b66d398ff9ac94918e955322bb')
+sha512sums=('7058526dfe0132bf8edc260538a18c3c169128162ad83646557e166af0bcb23166053de15e02d13eb84c2d68bdbc8bacd6a6730ade409ab34f8503ec9d69af46')
build() {
cd "${pkgname}-${pkgver}"