summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArne Beer2020-02-02 02:53:35 +0100
committerArne Beer2020-02-02 02:53:40 +0100
commitc59ff3f2a833229ea0f5e6a4967e203515796b53 (patch)
tree7a77b3b0ffe1839d275195cdeb6efeb4e6605604 /PKGBUILD
downloadaur-c59ff3f2a833229ea0f5e6a4967e203515796b53.tar.gz
Add binary pueue package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7342c76a87f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Arne Beer <privat@arne.beer>
+
+pkgname=pueue-bin
+pkgver='0.1.4'
+pkgrel=1
+arch=('any')
+pkgdesc='A command scheduler for shells'
+license=('MIT')
+conflicts=('pueue-git' 'pueue')
+provides=('pueue')
+url='https://github.com/nukesor/pueue'
+source=(
+ "https://github.com/Nukesor/pueue/archive/v${pkgver}.tar.gz"
+ "https://github.com/Nukesor/pueue/releases/download/v${pkgver}/pueue-linux-amd64"
+ "https://github.com/Nukesor/pueue/releases/download/v${pkgver}/pueued-linux-amd64"
+)
+sha256sums=(
+ '8e156d1037a88448219d9c5bdbc844799e616604985c86a83541f0a23481f302'
+ '039d11971a190562210fc9ee2a1504256fd1440b9471e1bbbc9bbb86eca3ce49'
+ '5933369d330b45e98adf2b7847b6d63314d590c7c78f4bf243a7189cc4b6fd4a'
+)
+
+
+package() {
+ install -Dm755 "pueue-linux-amd64" "${pkgdir}/usr/bin/pueue"
+ install -Dm755 "pueued-linux-amd64" "${pkgdir}/usr/bin/pueued"
+
+ tar xf "v${pkgver}.tar.gz"
+ cd "pueue-${pkgver}"
+
+ # Place systemd user service
+ install -Dm644 "utils/pueued.service" "${pkgdir}/usr/lib/systemd/user/pueued.service"
+
+ # Install zsh completions file
+ # Zsh is broken for now
+# install -Dm644 "utils/completions/_pueue" "${pkgdir}/usr/share/zsh/site-functions/_pueue"
+ install -Dm644 "utils/completions/pueue.bash" "${pkgdir}/usr/share/bash-completion/completions/pueue.bash"
+ install -Dm644 "utils/completions/pueue.fish" "${pkgdir}/usr/share/fish/completions/pueue.fish"
+
+ # Install License
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/pueue/LICENSE"
+}