summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 19:34:05 +0200
committersl1pkn072015-06-08 19:34:05 +0200
commite4a6e16db362d229e98a43ce2ce85f4d9290908f (patch)
treec1300d2e1f9cd8a65f418e1a4f95192ddf225a4d /PKGBUILD
downloadaur-e4a6e16db362d229e98a43ce2ce85f4d9290908f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..081305c3f241
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=pugixml-shared
+pkgver=1.6
+pkgrel=1
+pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support"
+url="http://pugixml.org/"
+arch=('x86_64' 'i686')
+license=('MIT')
+makedepends=('cmake')
+conflicts=('pugixml')
+provides=('pugixml')
+source=("http://github.com/zeux/pugixml/releases/download/v${pkgver}/pugixml-${pkgver}.tar.gz")
+sha1sums=('0c22fc238b209c9fd1802b74927f0b1e9f68011c')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake "../pugixml-${pkgver}/scripts" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=ON
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}