summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjonian2022-11-15 21:28:07 +0200
committerjonian2022-11-15 21:28:07 +0200
commit02347a3f9dc148dfd909a73b1d590fa54f9b7dc0 (patch)
treed21db07ec41739fcf0066ca94bfa08d81cb44892 /PKGBUILD
parent9f00d0870cce0113f23dad67588b9b5e0bb43f2b (diff)
downloadaur-02347a3f9dc148dfd909a73b1d590fa54f9b7dc0.tar.gz
version update to 2022111519
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 3 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb7335eaea63..cd5220182488 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_appname=pulsar
_reponame=pulsar-edit
-_tasktag=4704092994928640
-_datetag=2022111319
+_tasktag=4841168219930624
+_datetag=2022111519
pkgname="${_appname}-bin"
pkgver="1.63.${_datetag}"
@@ -14,7 +14,6 @@ arch=("x86_64")
url="https://github.com/${_reponame}/${_appname}"
license=("MIT")
depends=("libxkbfile" "ripgrep")
-makedepends=("asar")
optdepends=(
"ctags: symbol indexing support"
"git: Git and GitHub integration"
@@ -23,11 +22,10 @@ optdepends=(
provides=("${_appname}")
conflicts=("${_appname}")
source=("${_appname}-${pkgver}.deb::https://api.cirrus-ci.com/v1/artifact/task/${_tasktag}/binary/binaries/${_appname}_${pkgver}_amd64.deb")
-sha256sums=('bc814d81f4eea6e361fda039393f3516e6687547232016a83f6402f31d2a1cc4')
+sha256sums=('62616511221bee0a76185e843e1d842cb133d972b1e72fe3fbe0425f3302f029')
prepare() {
bsdtar xf data.tar.xz
- asar e opt/Pulsar/resources/app.asar asar
}
package() {
@@ -38,22 +36,6 @@ package() {
find "$pkgdir/opt/Pulsar/resources/app/ppm" -type d -name "spec" -exec rm -rf {} +
find "$pkgdir/opt/Pulsar/resources/app.asar.unpacked" -type d -name "spec" -exec rm -rf {} +
- # Fix core modules missing in settings. Remove when implemented upstream
- sed -i "s/=== 'apm'/=== 'ppm'/" "$pkgdir/opt/Pulsar/resources/app/ppm/lib/apm.js"
- sed -i "s/is 'apm'/is 'ppm'/" "$pkgdir/opt/Pulsar/resources/app/ppm/src/apm.coffee"
-
- # Fix featured not working. Remove when implemented upstream
- sed -i "/pack != null/c return pack != null && pack.releases != null;" \
- "$pkgdir/opt/Pulsar/resources/app/ppm/lib/featured.js"
-
- sed -i "s/pack?.releases?.latest?/pack?.releases?/" \
- "$pkgdir/opt/Pulsar/resources/app/ppm/src/featured.coffee"
-
- # This needs removal along with asar makedepend when fixed upstream
- mkdir -p "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/"
- mv asar/node_modules/github/bin "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/bin"
- rm -rf asar
-
mkdir -p "$pkgdir/usr/bin"
chmod +x "$pkgdir/opt/Pulsar/resources/${_appname}.sh"