summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpineEyE2020-10-11 15:38:20 +0200
committerSpineEyE2020-10-11 15:38:20 +0200
commitc5c38791c22567b94ac1ede40c23444be26ca6ab (patch)
tree2ea517825281257010ed316834f2c14019221e86 /PKGBUILD
parent312d6e16bc015f263ac3c6a693bb247949f96038 (diff)
downloadaur-c5c38791c22567b94ac1ede40c23444be26ca6ab.tar.gz
Upgrade version and use MarijnS95/absolute-volume-on-hsphfpd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD87
1 files changed, 52 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06693e7c3a7a..ec71c0ec695e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,46 @@
# Maintainer: SpineEyE <at gmail dot com>
-# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
-# Contributor: Corrado Primier <bardo@aur.archlinux.org>
-# Contributor: William Rea <sillywilly@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=pulseaudio-hsphfpd
-pkgname=(pulseaudio-hsphfpd libpulse-hsphfpd pulseaudio-{zeroconf,lirc,jack,bluetooth,equalizer}-hsphfpd)
+pkgname=(pulseaudio-hsphfpd libpulse-hsphfpd alsa-card-profiles-hsphfpd pulseaudio-{zeroconf,lirc,jack,bluetooth,equalizer,rtp}-hsphfpd)
pkgdesc="A fork of pulseaudio providing superior bluetooth headset functionality"
-pkgver=r9414.cbc09c9f1
-pkgrel=2
+pkgver=13.99.2+85+g95460f49e
+pkgrel=1
arch=(x86_64)
url="https://www.freedesktop.org/wiki/Software/PulseAudio/"
license=(GPL)
makedepends=(libasyncns libcap attr libxtst libsm libsndfile rtkit libsoxr
speexdsp tdb systemd dbus avahi bluez bluez-libs jack2 sbc
lirc openssl fftw orc gtk3 webrtc-audio-processing check git meson
- xmltoman libopenaptx)
-_branch=hsphfpd
-source=("git+https://gitlab.freedesktop.org/pali/pulseaudio.git#branch=$_branch"
- 0001-meson-Define-TUNNEL_SINK-for-module-tunnel-sink.patch)
-sha256sums=('SKIP'
- '4ff133e2847baad5bb6798b5816d67551cfba2efabb2f1f348628d7217abd07d')
+ xmltoman gst-plugins-base-libs)
+_commit=6101798c7a4fa5b8ce7f5589706b03d87a3aee76 # master
+source=("git+https://gitlab.freedesktop.org/pulseaudio/pulseaudio.git#commit=$_commit")
+sha256sums=('SKIP')
pkgver() {
- cd "${pkgname%-hsphfpd}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd pulseaudio
+ git describe --tags | sed 's/^v//;s/-/+/g'
}
prepare() {
cd pulseaudio
+ git fetch "https://gitlab.freedesktop.org/MarijnS95/pulseaudio.git" "absolute-volume-on-hsphfpd"
+ git checkout -B "MarijnS95/pulseaudio-absolute-volume-on-hsphfpd" FETCH_HEAD
+ git checkout master
+ git merge --ff -m "Merge branch 'MarijnS95/pulseaudio-absolute-volume-on-hsphfpd' into master" "MarijnS95/pulseaudio-absolute-volume-on-hsphfpd"
+
# Freeze version before patching
./git-version-gen doesnt-exist >.tarball-version
-
- # https://bugs.archlinux.org/task/63755
- git apply -3 ../0001-meson-Define-TUNNEL_SINK-for-module-tunnel-sink.patch
}
build() {
arch-meson pulseaudio build \
- -D gcov=false \
+ -D alsadatadir=/usr/share/alsa-card-profile/mixer \
-D pulsedsp-location='/usr/\$LIB/pulseaudio' \
+ -D stream-restore-clear-old-devices=true \
-D udevrulesdir=/usr/lib/udev/rules.d
- ninja -C build
+ meson compile -C build
}
check() {
@@ -61,9 +59,15 @@ _pick() {
}
package_pulseaudio-hsphfpd() {
- depends=("libpulse-hsphfpd=$pkgver-$pkgrel" rtkit libltdl speexdsp tdb orc libsoxr
- webrtc-audio-processing)
- optdepends=('pulseaudio-alsa-hsphfpd: ALSA configuration (recommended)')
+ depends=("libpulse-hsphfpd=$pkgver-$pkgrel" alsa-card-profiles rtkit libltdl speexdsp
+ tdb orc libsoxr webrtc-audio-processing)
+ optdepends=('pulseaudio-alsa-hsphfpd: ALSA configuration (recommended)'
+ 'pulseaudio-zeroconf-hsphfpd: Zeroconf support'
+ 'pulseaudio-lirc-hsphfpd: IR (lirc) support'
+ 'pulseaudio-jack-hsphfpd: Jack support'
+ 'pulseaudio-bluetooth-hsphfpd: Bluetooth support'
+ 'pulseaudio-equalizer-hsphfpd: Graphical equalizer'
+ 'pulseaudio-rtp-hsphfpd: RTP and RAOP support')
backup=(etc/pulse/{daemon.conf,default.pa,system.pa})
install=pulseaudio.install
replaces=('pulseaudio-xen<=9.0' 'pulseaudio-gconf<=11.1')
@@ -80,14 +84,6 @@ package_pulseaudio-hsphfpd() {
cd "$pkgdir"
- # Assumes that any volume adjustment is intended by the user, who can control
- # each app's volume. Misbehaving clients can trigger earsplitting volume
- # jumps. App volumes can diverge wildly and cause apps without their own
- # volume control to fall below sink volume; a sink-only volume control will
- # suddenly be unable to make such an app loud enough.
- sed -e '/flat-volumes/iflat-volumes = no' \
- -i etc/pulse/daemon.conf
-
# Superseded by socket activation
sed -e '/autospawn/iautospawn = no' \
-i etc/pulse/client.conf
@@ -103,7 +99,7 @@ package_pulseaudio-hsphfpd() {
rm -r etc/dbus-1
-### Split libpulse
+ # Split packages
_pick libpulse etc/pulse/client.conf
_pick libpulse usr/bin/pa{cat,ctl,dsp,mon,play,rec,record}
_pick libpulse usr/lib/libpulse{,-simple,-mainloop-glib}.so*
@@ -114,7 +110,8 @@ package_pulseaudio-hsphfpd() {
_pick libpulse usr/share/man/man5/pulse-client.conf.5
_pick libpulse usr/share/vala
-### Split modules
+ _pick alsa-card-profiles usr/share/alsa-card-profile
+
local moddir=usr/lib/pulse-$pulsever/modules
_pick zeroconf $moddir/libavahi-wrap.so
@@ -132,6 +129,10 @@ package_pulseaudio-hsphfpd() {
_pick equalizer $moddir/module-equalizer-sink.so
_pick equalizer usr/bin/qpaeq
+
+ _pick rtp $moddir/lib{rtp,raop}.so
+ _pick rtp $moddir/module-rtp-{send,recv}.so
+ _pick rtp $moddir/module-raop-sink.so
}
package_libpulse-hsphfpd() {
@@ -145,6 +146,15 @@ package_libpulse-hsphfpd() {
mv libpulse/* "$pkgdir"
}
+package_alsa-card-profiles-hsphfpd() {
+ pkgdesc="ALSA card profiles shared by PulseAudio"
+ provides=("alsa-card-profiles=$pkgver-$pkgrel")
+ conflicts=(alsa-card-profiles)
+ license=(LGPL)
+
+ mv alsa-card-profiles/* "$pkgdir"
+}
+
package_pulseaudio-zeroconf-hsphfpd(){
pkgdesc="Zeroconf support for PulseAudio"
depends=("pulseaudio-hsphfpd=$pkgver-$pkgrel" avahi openssl)
@@ -182,12 +192,19 @@ package_pulseaudio-bluetooth-hsphfpd(){
}
package_pulseaudio-equalizer-hsphfpd(){
- pkgdesc="Equalizer for PulseAudio"
- depends=("pulseaudio-hsphfpd=$pkgver-$pkgrel" python-{pyqt5,dbus,sip} fftw)
+ pkgdesc="Graphical equalizer for PulseAudio"
+ depends=("pulseaudio-hsphfpd=$pkgver-$pkgrel" python-{pyqt5,dbus} fftw)
provides=("pulseaudio-equalizer=$pkgver-$pkgrel")
conflicts=(pulseaudio-equalizer)
mv equalizer/* "$pkgdir"
}
+package_pulseaudio-rtp-hsphfpd(){
+ pkgdesc="RTP and RAOP support for PulseAudio"
+ depends=("pulseaudio=$pkgver-$pkgrel" gst-plugins-base-libs)
+
+ mv rtp/* "$pkgdir"
+}
+
# vim:set sw=2 et: