summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhayao2020-11-27 22:07:35 +0900
committerhayao2020-11-27 22:07:35 +0900
commitad53dbe5e43bb7278f15520967793fbdf53d9c88 (patch)
treedc9195b24a9539af3e021fbd8df0ed4799252646 /PKGBUILD
parent87057bd920d6f9382a608401235498b3bbca6bd5 (diff)
downloadaur-ad53dbe5e43bb7278f15520967793fbdf53d9c88.tar.gz
[update] : Updated pulseaudio version
[update] : Get the version of puleseaudio from repository or datebase [add] : Added .gitignore
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 23 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57a095093770..20226eb0e6d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,25 @@
pkgname="pulseaudio-modules-bt"
pkgver="1.4"
-pulseaudio_ver="13.99.2"
-pkgrel="3"
+
+
+#-- PulseAudio --#
+pulseaudio_pkgname="extra/pulseaudio"
+if pacman -Qq "$(basename "${pulseaudio_pkgname}")" 2> "/dev/null" 1>&2; then
+ # If pulseaudio is installed, use the version of installed pulseaudio.
+ pulseaudio_ver="$(pacman -Q "$(basename "${pulseaudio_pkgname}")" | cut -d ' ' -f 2 | cut -d '-' -f 1)"
+else
+ # If pulseaudio is not installed, use the version from offcial repository.
+ pulseaudio_ver="$(pacman -Sp --print-format '%v' "${pulseaudio_pkgname}" | cut -d '-' -f 1)"
+fi
+
+# if it is failed to get the version of pulseaudio, use the hard coded one.
+if [[ -v pulseaudio_ver ]]; then
+ pulseaudio_ver="14.0"
+fi
+
+
+pkgrel="4"
pkgdesc="PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support"
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -16,17 +33,17 @@ optdepends=("libavcodec.so>=58: aptX Classic, aptX HD support"
provides=("pulseaudio-bluetooth" "pulseaudio-modules-bt-git")
conflicts=("pulseaudio-bluetooth" "pulseaudio-modules-bt-git")
-source=("https://github.com/EHfive/pulseaudio-modules-bt/archive/v${pkgver}.zip"
- "https://github.com/pulseaudio/pulseaudio/archive/v${pulseaudio_ver}.zip")
+source=("pulseaudio-modules-bt.zip::https://github.com/EHfive/pulseaudio-modules-bt/archive/v${pkgver}.zip"
+ "pulseaudio.zip::https://github.com/pulseaudio/pulseaudio/archive/v${pulseaudio_ver}.zip")
md5sums=(
'711a7f930321e56706acdb441de0e432'
- '6f04e194199f39ffba0b026a770e990d'
+ 'SKIP'
)
sha512sums=(
"5c3ed59dec46a1a9cc2f359ac1d28a82a50a5dea47a268a10601b95a8e17a68dd00ba7628c429271349bae290f461abeb1a4a3715b1833c71d7f82f9a902fe2d"
- "61b24aac1b722cd611be88241551e6b345532b55d9f718ae784ec6eee135d7ba8460ea83b4c2de5b970e8af4af39c32255ff170f026156b0d22c988bc5499a6a"
+ "SKIP"
)
prepare() {