summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-06-17 17:19:14 -0600
committerMark Wagie2021-06-17 17:19:14 -0600
commit1bdd6e9ed7a9f85414694a797ad5b14cf05a20a5 (patch)
tree164c2d276dab7f3bccc5f272502908cb5ef2c826 /PKGBUILD
parent1c4760f10a204d2b7b125f25b46e97721b26ac97 (diff)
downloadaur-1bdd6e9ed7a9f85414694a797ad5b14cf05a20a5.tar.gz
PKGBUILD adjustments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a66f813b7270..08eb75f03ab9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
pkgname=('pulseeffects-legacy-git' 'gst-plugins-pulseeffects-legacy-git')
pkgbase=pulseeffects-legacy-git
-pkgver=4.8.4.r10.gc63827fc
-pkgrel=3
+pkgver=4.8.5.r1.g4ec1f83b
+pkgrel=1
pkgdesc='Audio Effects for Pulseaudio applications'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/wwmm/pulseeffects"
@@ -19,8 +19,9 @@ license=('GPL3')
depends=('gtk3' 'gtkmm3' 'glibmm' 'pulseaudio' 'gstreamer' 'gst-plugin-gtk'
'gst-plugins-bad' 'lilv' 'boost-libs' 'libsigc++' 'libsndfile'
'libsamplerate' 'zita-convolver' 'libebur128')
-makedepends=('git' 'meson' 'boost' 'itstool' 'appstream-glib' 'zam-plugins'
+makedepends=('git' 'meson' 'boost' 'itstool' 'zam-plugins'
'rubberband' 'rnnoise')
+checkdepends=('appstream-glib')
source=('git+https://github.com/wwmm/pulseeffects.git#branch=pulseaudio-legacy')
sha256sums=('SKIP')
@@ -34,6 +35,10 @@ build() {
meson compile -C build
}
+check() {
+ meson test -C build --print-errorlogs
+}
+
package_pulseeffects-legacy-git() {
depends=('gtk3' 'gtkmm3' 'glibmm' 'pulseaudio' 'gstreamer' 'gst-plugin-gtk'
'gst-plugins-bad' 'lilv' 'boost-libs' 'libsigc++'