summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Ortiz Manero2021-05-15 12:23:30 +0200
committerMario Ortiz Manero2021-05-15 12:23:30 +0200
commit8a360be70af04c9e74a735a9cdcc1875c2c56053 (patch)
treebcd225c4cbf18d865adf32ea2d7c3ef4677c40f3 /PKGBUILD
downloadaur-pulseeffects-presets.tar.gz
First release!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c70a18be29d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mario Ortiz Manero <marioortizmanero@gmail.com>
+# shellcheck disable=SC2034,SC2154
+pkgname=pulseeffects-presets
+_reponame="polybar-$pkgname" # expected to change
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='Control PulseAudio from the polybar status bar'
+url="https://github.com/marioortizmanero/${_reponame}"
+license=('custom:MIT')
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=('e9442386844149553773db654221af76')
+arch=('any')
+depends=(
+ 'bash'
+ 'pulseeffects'
+)
+optdepends=(
+)
+conflicts=(
+)
+
+package() {
+ set -e
+ cd "${_reponame}-$pkgver"
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -D -m755 "./pulseeffects-presets.bash" "$pkgdir/usr/bin/$pkgname"
+}