summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVaporeon2021-01-13 01:39:16 +1300
committerVaporeon2021-01-13 01:39:16 +1300
commit21aefe4821e4f841ce271a1a2378298a54118b91 (patch)
tree2a1ef0a3188affd23631f1d5e0c7109540f9b2af /PKGBUILD
parentf1ecacc7f5b8e566c0e0b75ec816b98b2cf3495b (diff)
downloadaur-21aefe4821e4f841ce271a1a2378298a54118b91.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 29 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cef3865b9b20..19cc5b2a1e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,50 @@
# Maintainer: Vaporeon <vaporeon@vaporeon.io>
pkgname=punes-git
-pkgver=r1199.83ab85c5
+pkgver=r1233.b8dc4659
pkgrel=1
pkgdesc="Nintendo Entertaiment System emulator"
arch=('x86_64')
url="http://forums.nesdev.com/viewtopic.php?t=6928"
license=('GPL2')
depends=('alsa-lib' 'desktop-file-utils' 'ffmpeg' 'hicolor-icon-theme' 'nvidia-cg-toolkit' 'qt5-base' 'qt5-svg')
-makedepends=('automake' 'git' 'qt5-tools')
+makedepends=('automake' 'cmake' 'git' 'qt5-tools')
conflicts=('punes')
provides=('punes')
source=("git+https://github.com/punesemu/puNES.git")
md5sums=('SKIP')
+#breaks internal lib7zip
+options=('!buildflags')
+
pkgver() {
- cd puNES
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd puNES
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/puNES"
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cd "${srcdir}"/puNES
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/puNES"
- make DESTDIR="$pkgdir" install
- #idk what the deal with this mimeinfo cache is, it seems to come and go
- rm -f "$pkgdir"/usr/share/applications/mimeinfo.cache
+ #As of 11 January 2021 "make install" appears to be broken
+ #cd "${srcdir}"/puNES
+ #make DESTDIR="${pkgdir}" install
+ #rm -f "${pkgdir}"/usr/share/applications/mimeinfo.cache
+
+ #Install manually.
+ cd "${srcdir}"/puNES/misc
+ for i in 16 32 48 256; do
+ icon=hicolor_apps_${i}x${i}_punes.png
+ theme=`echo $icon | cut -d_ -f1`
+ context=`echo $icon | cut -d_ -f2`
+ size=`echo $icon | cut -d_ -f3`
+ iconfile=`echo $icon | cut -d_ -f4`
+ install -Dm 644 ./$icon "${pkgdir}"/usr/share/icons/$theme/$size/$context/$iconfile
+ done
+ install -Dm 644 ./punes.desktop "${pkgdir}"/usr/share/applications/punes.desktop
+ cd "${srcdir}"/puNES/src
+ install -Dm 755 ./punes "${pkgdir}"/usr/bin/punes
}