summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:58:57 +0200
committerAlbert Graef2015-06-13 22:58:57 +0200
commitd5ed5b59e36df9146e0c61a4112332a23840cd7a (patch)
tree386988095cac00debc3514dad60d23c06a5481b4 /PKGBUILD
downloadaur-d5ed5b59e36df9146e0c61a4112332a23840cd7a.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec50281df539
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# -*- shell-script -*-
+# Contributor: Mikko Sysikaski mikko.sysikaski at gmail dot com
+# Updated by Stephen Diehl - sdiehl@clarku.edu
+# Maintainer: Alastair Pharo asppsa at gmail dot com
+# Maintainer: Albert Graef <aggraef@gmail.com>
+
+pkgname=pure
+pkgver=0.64
+pkgrel=2
+pkgdesc="Pure is a modern-style functional programming language based on term rewriting."
+arch=("i686" "x86_64")
+license=('GPL3' 'LGPL3')
+url="http://purelang.bitbucket.org/"
+depends=('llvm35' 'gmp' 'mpfr' 'readline')
+optdepends=("pure-docs: online documentation"
+ "pcre: Perl regex support"
+ "w3m: access to help in interactive mode"
+ "emacs-pure-mode: editing Pure files from Emacs"
+ "texmacs-pure: embedding Pure sessions in TeXmacs")
+groups=(pure-complete pure-base)
+source=("https://bitbucket.org/purelang/pure-lang/downloads/$pkgname-$pkgver.tar.gz")
+md5sums=('399b0a5cb6bbf0042ce42f9a857e332e')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ # For Perl5 regex support, at present you still need to add --with-pcre
+ # below (and make sure that you have pcre installed). This may become the
+ # default in the future.
+ ./configure --prefix=/usr --without-elisp --without-texmacs --enable-release
+ make || return 1
+ # check that the interpreter is working
+ make check || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install || return 1
+}