summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjoneshf2015-07-03 12:17:07 -0700
committerjoneshf2015-07-03 12:19:12 -0700
commit6c660a6dda33083d25454129f5f851aa9f13cc87 (patch)
treec0ed01af4cf02b766b580f777c0fa47518fe4549 /PKGBUILD
parent767c22a60aa286d04f13df28aab2a94ac118948f (diff)
downloadaur-6c660a6dda33083d25454129f5f851aa9f13cc87.tar.gz
Updated `update_version.sh`
For some reason `RPATH` issues have arisen. This is probably due to cabal, but we just delete them alltogether. Hopefully nothing breaks due to it...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be6a0c424c42..ef097d9684c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hardy Jones <jones3 dot hardy at gmail dot com>
pkgname=purescript-bin
-pkgver=0.6.9.5
+pkgver=0.7.0
pkgrel=1
pkgdesc="A strongly, statically typed language compiling to JavaScript."
arch=('x86_64')
@@ -9,14 +9,15 @@ license=('MIT')
depends=('glibc' 'gmp' 'gcc-libs' 'libtinfo')
provides=('purescript')
source=("https://github.com/joneshf/purescript/releases/download/v$pkgver/linux64.tar.gz")
-sha512sums=('2f9e267cd171816a17affcf90c68c5bdec72ee4f12e9de521fb3ec30b1c3e92c6603e775282f2e29b31f31f4c3c3a32b8ae2f98e0fd504e1cea3b94cab56a9c7')
+sha512sums=('7ba26a530067f45749831b86605f6bdeedba08812e3beabb7fc636c26380328aa8102945b5e61ece7ed674e77286ed30209020cf9a08da352171d3c4eff51f95')
package() {
cd "${srcdir}"/purescript
install -D -m755 psc "${pkgdir}/usr/bin/psc"
install -D -m755 psc-docs "${pkgdir}/usr/bin/psc-docs"
- install -D -m755 psc-make "${pkgdir}/usr/bin/psc-make"
+ install -D -m755 psc-bundle "${pkgdir}/usr/bin/psc-bundle"
+ install -D -m755 psc-publish "${pkgdir}/usr/bin/psc-publish"
install -D -m755 psci "${pkgdir}/usr/bin/psci"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"