summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Whited2019-06-19 14:28:35 -0500
committerSam Whited2019-06-19 14:28:35 -0500
commit6937e9139191dc6b89643b14941b4080ddb40780 (patch)
tree3dbfee33ebf5852cac9dfaa0338fb85863d7a21d /PKGBUILD
downloadaur-6937e9139191dc6b89643b14941b4080ddb40780.tar.gz
Initial version v0.0.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dedfbc058eff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sam Whited <sam@samwhited.com>
+# Contributor: geno+dev@fireorbit.de
+
+pkgname=purism-chatty
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="XMPP and SMS messaging via libpurple and Modemmanager"
+url="https://source.puri.sm/Librem5/chatty"
+license=(LGPL2.1)
+arch=(i686 x86_64 armv6h armv7h)
+depends=(gtk3 libpurple)
+optdepends=('libpurple-lurch: XMPP E2E OMEMO encryption'
+ 'libpurple-carbons: XMPP Carbon Copy - Live multiple device support'
+ 'purple-xmpp-http-upload: XMPP HTTP Upload - Filesharing')
+makedepends=(pkg-config meson libhandy)
+provides=(purism-chatty)
+conflicts=(purism-chatty)
+source=("https://source.puri.sm/Librem5/chatty/-/archive/v${pkgver}/chatty-v${pkgver}.tar.bz2")
+sha256sums=('b86e1d027bb863b3cfedc6957ff34fb1413d97e15a6470c56d0c6a4c1d81917d')
+
+build() {
+ rm -rf build
+ arch-meson "chatty-v${pkgver}" build -Dexamples=false -Dgtk_doc=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}