summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustin Dray2015-05-28 13:07:38 +1000
committerJustin Dray2015-05-28 13:07:38 +1000
commit73863a029246be515b7e9237f16f128938cbbca1 (patch)
tree0ae95f885146f19c3de213d2683a25ef489337c8 /PKGBUILD
downloadaur-73863a029246be515b7e9237f16f128938cbbca1.tar.gz
Cleaned up organization for arch packages in prep for aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a775bcce8eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: Elder Marco <eldermarco at gmail dot com>
+
+pkgname=purple-events
+pkgver=0.2
+pkgrel=3
+pkgdesc="libpurple events handling plugin and library"
+license=('GPL3')
+url="https://github.com/sardemff7/purple-events"
+source=("https://github.com/downloads/sardemff7/$pkgname/$pkgname-$pkgver.tar.xz")
+makedepends=('perl-xml-parser' 'intltool')
+options=(!libtool)
+depends=('glib2' 'libpurple>=2.6.0')
+arch=('i686' 'x86_64')
+md5sums=('5cabec53fc7cedeefb59c44f00b08d40')
+
+build () {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+check () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
+package () {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}