summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlbert Graef2018-01-03 11:33:22 +0100
committerAlbert Graef2018-01-03 11:33:22 +0100
commit07d5969a400127ba445b1b8ce7306f156d977e57 (patch)
treeb6641faee51765887e8082b6f1b88fb8dfeb49b1 /PKGBUILD
parent650566d748bf6df63073f245bcad93bc5c408449 (diff)
downloadaur-07d5969a400127ba445b1b8ce7306f156d977e57.tar.gz
Fix up ImageMagick dependency (Gem needs libmagick6).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0218cb1a235..f6b7e546d41b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,7 +30,7 @@
# /usr/lib/purr-data, so that 3rd party externals know where to find these.
pkgname=purr-data
-pkgver=2.4.6.r3761.46ffba37
+pkgver=2.4.6.r3766.4af8d07b
pkgrel=1
pkgdesc="Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)"
url="https://git.purrdata.net/jwilkes/purr-data"
@@ -38,7 +38,7 @@ arch=('i686' 'x86_64')
license=('BSD')
depends=('bluez-libs' 'desktop-file-utils' 'dssi' 'fftw'
'flite1' 'fluidsynth' 'freeglut' 'ftgl' 'glew' 'gmerlin'
- 'gsl' 'gsm' 'hicolor-icon-theme' 'imagemagick' 'jack' 'ladspa' 'lame'
+ 'gsl' 'gsm' 'hicolor-icon-theme' 'libmagick6' 'jack' 'ladspa' 'lame'
'libdc1394' 'libdv' 'libgl' 'libiec61883' 'libjpeg' 'libquicktime'
'libxxf86vm' 'libtiff' 'libiec61883' 'libunicap' 'libraw1394'
'libsndobj-git' 'libv4l' 'libvorbis' 'portaudio'
@@ -58,9 +58,11 @@ options=('!makeflags' '!strip')
# deal with situations where upstream lags behind on already submitted merge
# requests with important bugfixes and additions.
source=("$pkgname::git+https://git.purrdata.net/aggraef/purr-data.git#branch=release"
- "RTcmix-pd-LCPLAY-stabilize.patch")
+ "RTcmix-pd-LCPLAY-stabilize.patch"
+ "gem-magick6-fixes.patch")
md5sums=('SKIP'
- '39c53063dc18681f29b12c08d9c453aa')
+ '39c53063dc18681f29b12c08d9c453aa'
+ '63c6794adbc47e4c239eeb50ed30bfa8')
# nw.js sdk binaries
nwjsname=nwjs-sdk
nwjsver=0.22.1
@@ -106,6 +108,8 @@ prepare() {
cp -a $srcdir/$nwjsname-v$nwjsver-linux-$_arch pd/nw/nw
# make the sources compile with gcc 6.1+
cd $srcdir/$pkgname/externals/rtcmix-in-pd && patch -Np1 < $srcdir/RTcmix-pd-LCPLAY-stabilize.patch
+ # make sure to link Gem with ImageMagick 6, it doesn't compile with 7
+ cd $srcdir/$pkgname && patch -Np1 < $srcdir/gem-magick6-fixes.patch
}
build() {