summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlbert Graef2016-10-14 11:52:28 +0200
committerAlbert Graef2016-10-14 11:52:28 +0200
commit250ae51d991c1bc769cd53f36801b3a297a181b8 (patch)
tree974d202964ea766d6cfa4520b6ef9d2e75f75764 /PKGBUILD
parent678d3bb74166b47ec7fc4ddb1dad4b08d98c1ac6 (diff)
downloadaur-250ae51d991c1bc769cd53f36801b3a297a181b8.tar.gz
Update to latest upstream source, nw.js update.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74745dfb3d52..4e6f8232add1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@
# under /usr/include/pd-l2ork.
pkgname=purr-data-git
-pkgver=r2763.e480121
+pkgver=r2952.615527c
pkgrel=1
pkgdesc="Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)"
url="https://git.purrdata.net/jwilkes/purr-data"
@@ -37,19 +37,17 @@ conflicts=('purr-data' 'pd-l2ork' 'pd-l2ork-git')
install=purr-data.install
options=('!makeflags')
source=("$pkgname::git+https://git.purrdata.net/jwilkes/purr-data.git"
- "Gem-pix_colorclassify.patch"
"RTcmix-pd-LCPLAY-stabilize.patch")
md5sums=('SKIP'
- '33dc1880e38ac8dbc7aa5075bfe49abd'
'39c53063dc18681f29b12c08d9c453aa')
# nw.js sdk binaries
nwjsname=nwjs-sdk
-nwjsver=0.15.4
+nwjsver=0.17.6
source_common="http://dl.nwjs.io/v$nwjsver/$nwjsname-v$nwjsver-linux"
source_i686=("$source_common-ia32.tar.gz")
source_x86_64=("$source_common-x64.tar.gz")
-md5sums_i686=('ab052c9580d9e9016cdd720f8f832337')
-md5sums_x86_64=('53d2c4fa98eae97b57e33a8ae49a0612')
+md5sums_i686=('5d878e8849c54e758884b285307e5955')
+md5sums_x86_64=('2a01edf88ed2f60ec1e0abf91ef2ce0c')
if [ "$CARCH" = "i686" ]; then
_arch="ia32"
@@ -79,8 +77,7 @@ prepare() {
rm -rf pd/nw/nw
cp -a $srcdir/$nwjsname-v$nwjsver-linux-$_arch pd/nw/nw
# make the sources compile with gcc 6.1+
- cd $srcdir/$pkgname/Gem && patch -Np1 < $srcdir/Gem-pix_colorclassify.patch
- cd $srcdir/$pkgname/l2ork_addons/rtcmix-in-pd && patch -Np1 < $srcdir/RTcmix-pd-LCPLAY-stabilize.patch
+ cd $srcdir/$pkgname/externals/rtcmix-in-pd && patch -Np1 < $srcdir/RTcmix-pd-LCPLAY-stabilize.patch
}
build() {