summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2016-08-29 21:23:09 -0300
committerRafael Fontenelle2016-08-29 21:27:39 -0300
commitd852d1d9359ce9e715feafd83ab05aff4e0c0e65 (patch)
tree938ee4558a5f835bd214ba01f4291da16923803a /PKGBUILD
parent7e73d44709feda3ca3078668c238eb797c5ccf58 (diff)
downloadaur-d852d1d9359ce9e715feafd83ab05aff4e0c0e65.tar.gz
Update to 2
Changes in this commit includes: - Set url in PKGBUILD as non-array (required by makepkg) - New script to start putty as root (required for Serial connection to access root device) - Desktop file for putty as root - Changes in optdepends to reflect putty-as-root option - Icons with better resolution (96x96 pixels) for XPM and PNG
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 25 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ebf66a602f2..3ab5924d7435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,35 @@
-# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
-
-# Needs to be merged with the main putty package. Icon will now show up in freedesktop.org compliant menus.
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+# Contributor: GI_Jack <iamjacksemail@hackermail.com>
pkgname=putty-freedesktop
-pkgver=1
+pkgver=2
pkgrel=1
pkgdesc="Icon and .desktop file for Putty"
arch=('any')
license=('MIT')
-url=('http://www.chiark.greenend.org.uk/~sgtatham/putty/')
+url='http://www.chiark.greenend.org.uk/~sgtatham/putty/'
depends=('putty')
-source=('putty.desktop' 'putty.png' 'putty.xpm')
-sha256sums=('5b4f98201719d406caeb6f9c73ce723d90681cb00fa747593b24ca255e6ddd6c'
- '42c841aa8c6bcdbc44cc131dc1246f25559d82c426bab0a70133b286b1f3bb21'
- 'e4d56c40fd0871868c59d0b83530ba9a9dca332f1d798248e739aee20fb5e831')
+optdepends=('sudo: privilege escalation for putty'
+ 'gksu: privilege escalation for putty'
+ 'xterm: privilege escalation for putty'
+ 'kdebase-runtime: privilege escalation for putty')
+source=('putty.desktop' 'putty.png' 'putty.xpm'
+ 'putty-root.desktop' 'su-to-putty.sh')
+sha256sums=('d33543cfd081f9a9fef3f5de0663b92142312d3d345faa559a771c7ef60dca69'
+ '50cd4712011ea5124fc999298e1ccb51e10ba4f6448e434dc5e46b80c6d9b18a'
+ 'd65139883171ed0119d9778ff4a89e6a8151a5ae97fcf8dc7cafb59df424377f'
+ '359c41850691bea8bdeb3331f9fa3abb2ff8871f1a236943a89c70a57ce82b09'
+ '2e32d76276675f2f5ed2ea996d95776ec3c7776ea04ba3fe96a28300ba8a3144')
package() {
- install -Dm644 "${srcdir}/putty.desktop" "${pkgdir}/usr/share/applications/putty.desktop"
- install -Dm644 "${srcdir}/putty.png" "${pkgdir}/usr/share/pixmaps/putty.png"
- install -m644 "${srcdir}/putty.xpm" "${pkgdir}/usr/share/pixmaps/putty.xpm"
+ install -Dm755 su-to-putty.sh \
+ "${pkgdir}/usr/share/${pkgname}/su-to-putty.sh"
+ install -Dm644 putty.desktop \
+ "${pkgdir}/usr/share/applications/putty.desktop"
+ install -m644 putty-root.desktop \
+ "${pkgdir}/usr/share/applications/putty-root.desktop"
+ install -Dm644 putty.png \
+ "${pkgdir}/usr/share/pixmaps/putty.png"
+ install -m644 putty.xpm \
+ "${pkgdir}/usr/share/pixmaps/putty.xpm"
}