summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNeoTheFox2017-06-19 12:12:54 +0300
committerNeoTheFox2017-06-19 12:12:54 +0300
commit47c8e45b203c70fbf7c2af404321a5200ab16754 (patch)
tree852afcf9d24cc0d28745d33fc8f5edcb18d5d220 /PKGBUILD
downloadaur-47c8e45b203c70fbf7c2af404321a5200ab16754.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a985a45cd95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=pxdo-git
+pkgver=c77d029
+pkgrel=1
+pkgdesc="Python script for querying X-server information and manipulating X-windows"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/xhsdf/rtile"
+license=('GPL')
+depends=('python-xlib')
+makedepends=('git')
+conflicts=('pxdo')
+provides=('pxdo')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=("$pkgname"::'git://github.com/xhsdf/pxdo.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --always --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "pxdo.py" "$pkgdir/usr/bin/pxdo.py"
+}