summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Chen2015-05-30 16:01:08 +1200
committerAndrew Chen2015-05-30 16:01:08 +1200
commit37abbe2578a82a6225830a6966f8ed358fa40b99 (patch)
tree52b4610caea16d3972193012ffe20218c1a107d5 /PKGBUILD
downloadaur-37abbe2578a82a6225830a6966f8ed358fa40b99.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71297950b178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Vladimir Kutyavin <vlkut@bk.ru>
+pkgname=pxview
+pkgver=0.2.5
+pkgrel=2
+pkgdesc='Program to read Paradox database files and output them as csv, sql, sqlite or html (configured without "--with-sqlite" option)'
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://pxlib.sourceforge.net/"
+depends=('pxlib')
+source=(http://downloads.sourceforge.net/sourceforge/pxlib/${pkgname}_${pkgver}.orig.tar.gz)
+md5sums=('954dbb0371986d6e27802de8043c6807')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --with-gsf
+
+ make LDFLAGS=-lgobject-2.0
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make DESTDIR=$pkgdir install
+}