summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFuzzyCheese2021-04-27 13:18:04 -0500
committerFuzzyCheese2021-04-27 13:18:04 -0500
commita1b82c20d9ef9cd1e41f0b1f0848d9264444162e (patch)
tree2fdf43de39ed55b001c84b46e14b0129b867feea /PKGBUILD
downloadaur-a1b82c20d9ef9cd1e41f0b1f0848d9264444162e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b34274200912
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=py3-chirp-git
+pkgver=r54.1e8bf92
+pkgrel=1
+pkgdesc="GUI tool for programming ham radios, built from a fork of CHIRP for testing with Python 3."
+arch=('any')
+url="https://github.com/mpoletiek/py3-CHIRP"
+license=('GPL3')
+depends=('python-wxpython' 'python-six' 'python-lxml' 'python-pyserial' 'python-future' 'python-gobject' 'curl')
+optdepends=('hamradio-menus: XDG menus for ham radio software')
+makedepends=()
+provides=('chirp')
+conflicts=('chirp')
+source=('git+https://github.com/mpoletiek/py3-CHIRP')
+md5sums=('SKIP')
+
+pkgver() {
+ cd py3-CHIRP
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd py3-CHIRP
+ sed -i 's|/usr/sbin|/usr/bin|' setup.py
+ # catches most of the remaining issues
+ 2to3 -w chirp/drivers/*.py
+}
+
+package() {
+ cd py3-CHIRP
+ python3 setup.py install --root="$pkgdir" --optimize=0
+} \ No newline at end of file