summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormcgillij2023-05-03 18:07:32 -0300
committermcgillij2023-05-03 18:07:32 -0300
commit10cf5e526c00b8f9ee866bb0ae97efb8b373f132 (patch)
treefee2e48f0375caed72adfe7cdbda9b8e41dd3e2d /PKGBUILD
parentcafdc56118c415c3254edc99957e3a5561e6b962 (diff)
downloadaur-10cf5e526c00b8f9ee866bb0ae97efb8b373f132.tar.gz
update to new python-build and new amdfan
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 915063053cd7..bcb53b2a149b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
pkgname=py3status-amdfan
pkgdesc="Py3status module for monitoring fan and temp of amdgpu video cards"
-pkgver=0.1.8
+pkgver=0.1.9
pkgrel=1
arch=('any')
license=('MIT')
depends=('python' 'py3status' 'amdfan')
-makedepends=('python-setuptools')
+makedepends=('python-installer' 'python-build' 'python' 'py3status' 'python-poetry')
url="https://github.com/mcgillij/py3status-amdfan"
source=("https://github.com/mcgillij/py3status-amdfan/releases/download/$pkgver/py3status_amdfan-$pkgver.tar.gz")
-md5sums=('ecca7ebb9186ee80c7306cfe42cca694')
+md5sums=('3c51afa5f238f1955d88b10d12d40d22')
build() {
cd "$srcdir/py3status_amdfan-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/py3status_amdfan-$pkgver"
- python setup.py install --prefix=/usr --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}