summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChih-Hsuan Yen2019-08-28 20:46:17 +0800
committerChih-Hsuan Yen2019-08-28 20:46:17 +0800
commit9582ce28dec143e64d9cd1c769a21121f4a3671f (patch)
tree78d7f243e70e4353276679bb52f7c868ca2daec0 /PKGBUILD
parent188fa41a9b412498dfb788e0def94736647d2aa3 (diff)
downloadaur-9582ce28dec143e64d9cd1c769a21121f4a3671f.tar.gz
Fix check() with pytest 5 and more
* Add contributors from extra/pyalpm * Add missing makedepends noticed by bartus
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c87f8bedf423..03c918a4571c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor: bartus
+# Contributor: Rémy Oudompheng <remy@archlinux.org>
# Contributor: Dave Reisner <d@falconindy.com>
_pkgname=pyalpm
pkgname=$_pkgname-git
-pkgver=0.8.4.r23.gacd7fdc
+pkgver=0.8.4.r100.gbca42ad
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('x86_64')
url="https://git.archlinux.org/pyalpm.git/"
license=('GPL3')
depends=('python>=3.6' 'pacman>=5')
-makedepends=('git')
+makedepends=('git' 'python-setuptools')
checkdepends=('python-pytest')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
@@ -24,6 +26,12 @@ pkgver() {
)
}
+prepare() {
+ cd $_pkgname
+ # https://github.com/archlinux/pyalpm/pull/31
+ sed -i 's#str(excinfo)#str(excinfo.value)#' test/*.py
+}
+
build() {
cd $_pkgname