summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Ebbert2020-12-07 10:43:45 +0100
committerDaniel Ebbert2020-12-07 10:43:45 +0100
commit07e3b2083978817587043cc6f7afbff901e37d00 (patch)
tree68b40247fd71bb008fb9a047d2775af9357c8d15 /PKGBUILD
parent421852269470bee5e39e35e2b871abe2c1e67f5d (diff)
downloadaur-07e3b2083978817587043cc6f7afbff901e37d00.tar.gz
Update to v3.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 12 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6681644bb46a..ee11606ab695 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,16 @@
#Maintainer: Jan Koppe <post@jankoppe.de>
pkgname=pyca
-pkgver=3.2
-pkgrel=7
+pkgver=3.3
+pkgrel=1
pkgdesc="Python Capture Agent for Opencast"
arch=('any')
url="https://github.com/opencast/pyCA"
license=('LGPL')
depends=('python-pycurl' 'python-dateutil' 'python-configobj' 'python-sqlalchemy' 'python-sdnotify' 'python-psutil' 'python-flask')
optdepends=('gunicorn: wsgi web interface' 'ffmpeg: video and audio recording')
-source=("https://github.com/opencast/pyCA/archive/v$pkgver.tar.gz"
- "pyca.install"
- "pyca.service"
- "pyca-ui.service"
- "pyca-agentstate.service"
- "pyca-capture.service"
- "pyca-ingest.service"
- "pyca-schedule.service")
+source=("https://github.com/opencast/pyCA/archive/v$pkgver.tar.gz")
install="pyca.install"
-md5sums=('9db4a8d30754458a624c23af1b1a7572'
- 'd16c4e1a394f0cf356f65555e8cb0334'
- 'ad2dff096f5fd249f30137088ea5130d'
- 'e00ff2fb7ded9f6ef2c01b6dccb8bb7c'
- '00d4bc93ddd9de5226cbfad53e1b4d10'
- 'eac3ed5d9f9766bcc4b455b69056b351'
- 'e0ee6375752f98e3dfca8c9a5b2b776f'
- 'f17d472d7de8f63e6b563fd38ac81314')
+md5sums=('0ef885b91d309b69399f91b6d36e84ff')
backup=('etc/pyca.conf')
prepare() {
@@ -38,17 +24,17 @@ prepare() {
package() {
cd pyCA-"${pkgver}"
- install -Dm 644 "${srcdir}"/pyca.service "${pkgdir}"/usr/lib/systemd/system/pyca.service
- install -Dm 644 "${srcdir}"/pyca-agentstate.service "${pkgdir}"/usr/lib/systemd/system/pyca-agentstate.service
- install -Dm 644 "${srcdir}"/pyca-capture.service "${pkgdir}"/usr/lib/systemd/system/pyca-capture.service
- install -Dm 644 "${srcdir}"/pyca-ingest.service "${pkgdir}"/usr/lib/systemd/system/pyca-ingest.service
- install -Dm 644 "${srcdir}"/pyca-schedule.service "${pkgdir}"/usr/lib/systemd/system/pyca-schedule.service
- install -Dm 644 "${srcdir}"/pyca-ui.service "${pkgdir}"/usr/lib/systemd/system/pyca-ui.service
+ install -Dm 644 init/systemd/pyca.service "${pkgdir}"/usr/lib/systemd/system/pyca.service
+ install -Dm 644 init/systemd/pyca-agentstate.service "${pkgdir}"/usr/lib/systemd/system/pyca-agentstate.service
+ install -Dm 644 init/systemd/pyca-capture.service "${pkgdir}"/usr/lib/systemd/system/pyca-capture.service
+ install -Dm 644 init/systemd/pyca-ingest.service "${pkgdir}"/usr/lib/systemd/system/pyca-ingest.service
+ install -Dm 644 init/systemd/pyca-schedule.service "${pkgdir}"/usr/lib/systemd/system/pyca-schedule.service
+ install -Dm 644 init/systemd/pyca-ui.service "${pkgdir}"/usr/lib/systemd/system/pyca-ui.service
install -dm 755 "${pkgdir}"/var/lib/pyca/recordings
- install -dm 755 "${pkgdir}"/usr/lib/python3.8/site-packages/pyca
+ install -dm 755 "${pkgdir}"/usr/lib/python3.9/site-packages/pyca
install -Dm 644 etc/pyca.conf "${pkgdir}"/etc/pyca.conf
- cp -dr --no-preserve=ownership pyca/* "${pkgdir}"/usr/lib/python3.8/site-packages/pyca/
+ cp -dr --no-preserve=ownership pyca/* "${pkgdir}"/usr/lib/python3.9/site-packages/pyca/
install -Dm 755 start.sh "${pkgdir}"/usr/bin/pyca
}