summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Koppe2017-03-21 13:13:43 +0100
committerJan Koppe2017-03-21 13:13:43 +0100
commit145a323acaee73bc5c6ed21b915e3d822b8bd9ae (patch)
tree9192b323f04f794c7d9a5ce9bf47559483fff35d /PKGBUILD
parentbda447d4e12953256aacf65589289f303b409b28 (diff)
downloadaur-145a323acaee73bc5c6ed21b915e3d822b8bd9ae.tar.gz
add missing dependency, backport small fix
* adds the missing python-flask dependency * backports a small fix in the agentstate service, see https://github.com/opencast/pyCA/pull/96
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d5f77109268..34c40432b8cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
#Maintainer: Jan Koppe <post@jankoppe.de>
pkgname=pyca
pkgver=2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python Capture Agent for Opencast"
arch=('any')
url="https://github.com/opencast/pyCA"
license=('LGPL')
-depends=('gnutls' 'python-dateutil' 'python-configobj' 'python-pycurl' 'python-sqlalchemy')
+depends=('gnutls' 'python-dateutil' 'python-configobj' 'python-flask' 'python-pycurl' 'python-sqlalchemy')
optdepends=('gunicorn: wsgi web interface')
source=("https://github.com/opencast/pyCA/archive/v$pkgver.tar.gz"
"pyca.install"
@@ -27,8 +27,8 @@ prepare() {
sed -i 's/directory\s*=.*/directory = \/var\/lib\/pyca\/recordings\//' etc/pyca.conf
sed -i 's/#database\s*=.*/database = sqlite:\/\/\/\/var\/lib\/pyca\/pyca.db/' etc/pyca.conf
- # fix startup binary
- # sed -i 's/pyca/pyca.__main__/g' start.sh
+ # Backport a minor fix in agentstate worker, see https://github.com/opencast/pyCA/pull/96
+ sed -i 's/while not terminate and/while not terminate() and/g' pyca/agentstate.py
}
package() {