summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2019-09-09 19:08:59 +0200
committerKr1ss2019-09-09 19:08:59 +0200
commit2217c0df890373f5e33e92ba992158f2b7e644ac (patch)
tree3b5a333c811fce97daf7edcfd73b42c3e3e2af9d /PKGBUILD
parentc494f06d99b0286bb026b03a545139d44f21d202 (diff)
downloadaur-2217c0df890373f5e33e92ba992158f2b7e644ac.tar.gz
rationalize some cd's to reduce redundance
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd19a6def56e..960f9f7db371 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,14 +41,15 @@ prepare() {
}
build() {
+ cd "pycharm-community-$_buildver/helpers/pydev/"
+
# use absolute paths to the python executables so that users with an activated
# virtual environment (like e.g. anaconda) can build without issues
- /usr/bin/python2 "$srcdir/pycharm-community-$_buildver/helpers/pydev/setup_cython.py" build_ext --inplace
- /usr/bin/python3 "$srcdir/pycharm-community-$_buildver/helpers/pydev/setup_cython.py" build_ext --inplace
+ /usr/bin/python2 "./setup_cython.py" build_ext --inplace
+ /usr/bin/python3 "./setup_cython.py" build_ext --inplace
}
package() {
- cd "$srcdir"
mkdir -p "$pkgdir/opt/$pkgname"
cp -R "pycharm-community-$_buildver/"* "$pkgdir/opt/$pkgname/"