summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2018-12-28 01:49:58 +0100
committerKr1ss2018-12-28 01:49:58 +0100
commit5f40a78ef6944d502726939a7110b6d253e76fc5 (patch)
tree82a01536d27a9ad8839b8224a4577b1ccf047ac7 /PKGBUILD
parent3a24e91a08888ecc50b230a426c4bbc39a1f6fff (diff)
downloadaur-5f40a78ef6944d502726939a7110b6d253e76fc5.tar.gz
pre-compile the pydev-debugger in build()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37684f4e1d97..c9f077af8ca7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgname=pycharm-community-eap
_buildver=183.5153.12
_pkgver=2018.3.3
pkgver=$_pkgver.$_buildver
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc='Powerful Python and Django IDE, Early Access Program (EAP) build. Community edition.'
arch=(any)
@@ -30,6 +30,9 @@ build() {
StartupNotify=true
StartupWMClass=jetbrains-pycharm-ce
EOF
+
+ python2 "$srcdir/pycharm-community-$_pkgver/helpers/pydev/setup_cython.py" build_ext --inplace
+ python3 "$srcdir/pycharm-community-$_pkgver/helpers/pydev/setup_cython.py" build_ext --inplace
}
package() {