summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2019-04-04 21:30:36 +0200
committerKr1ss2019-04-04 21:30:36 +0200
commita5abd92f856f2c3cae68786696baaf3b1f0e9d0c (patch)
tree7fbc688ad322880a3b05e7a0cf26c48e2e125afa /PKGBUILD
parentf2bce32567d78ad9d1a09c02934302e4ff53418a (diff)
downloadaur-a5abd92f856f2c3cae68786696baaf3b1f0e9d0c.tar.gz
use system python binaries to build PyDev debugger
Users with an activated virtual python environment (such as Anaconda) were unable to precompile the PyDev speeder, causing build() to abort with an error.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddd706e4ab86..09b399b61081 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _buildver=191.6605.12
_pkgver=2019.1.1
_eap=n
pkgver=$_pkgver.$_buildver
-pkgrel=1
+pkgrel=2
epoch=3
pkgdesc='Powerful Python and Django IDE, Early Access Program (EAP) build. Community edition.'
arch=(any)
@@ -38,8 +38,10 @@ prepare() {
}
build() {
- python2 "$srcdir/pycharm-community-$_filever/helpers/pydev/setup_cython.py" build_ext --inplace
- python3 "$srcdir/pycharm-community-$_filever/helpers/pydev/setup_cython.py" build_ext --inplace
+ # use absolute paths to the python executables so that users with an activated
+ # virtual environment (like e.g. anaconda) can build without issues
+ /usr/bin/python2 "$srcdir/pycharm-community-$_filever/helpers/pydev/setup_cython.py" build_ext --inplace
+ /usr/bin/python3 "$srcdir/pycharm-community-$_filever/helpers/pydev/setup_cython.py" build_ext --inplace
}
package() {