summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2020-08-27 16:12:34 +0200
committerKr1ss2020-08-27 16:12:34 +0200
commitae4a4c97a6ead9b72658295d479f8a34a573e6bf (patch)
treed2e4ba054b4bdabac393a01136ed5943121af148 /PKGBUILD
parent7e521188029ddee0e00d6c82b834331ce32ca67f (diff)
downloadaur-ae4a4c97a6ead9b72658295d479f8a34a573e6bf.tar.gz
v2020.2.1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 29 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9bbd5a268e1..7ca1f2e8eb60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,72 +1,72 @@
# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
# Contributor : Phil Schaf <flying-sheep(at)web.de>
+#####################################################################################################
+ ## NOTE: Removing python2 as mandatory makedep; if you want to have a precomiled Python 2 debugger ##
+ ## packaged, make sure that `python2-setuptools` is installed _before_ building this package. ##
+ #####################################################################################################
pkgname=pycharm-community-eap
-_buildver=202.6948.52
+_buildver=202.6948.78
_pkgver=2020.2.1
-_eap=y
+_eap=n
pkgver="$_pkgver.$_buildver"
pkgrel=1
epoch=7
-pkgdesc='Powerful Python and Django IDE, Early Access Program (EAP) build. Community edition.'
+pkgdesc='Powerful Python and Django IDE, Early Access Program (EAP) build, Community Edition'
arch=('any')
-url=http://www.jetbrains.com/pycharm/
+url=http://www.jetbrains.com/pycharm
license=('Apache')
provides=('pycharm-community-edition')
conflicts=('pycharm-community-edition')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools') # 'python2-setuptools'
depends=('libdbusmenu-glib')
options=('!strip')
-if [ "$_eap" = y ]; then
- _filever="$_buildver"
-else
- _filever="$_pkgver"
-fi
+_filever="$([ $_eap = y ] && echo -n $_buildver || echo -n $_pkgver)"
source=("https://download.jetbrains.com/python/pycharm-community-$_filever.tar.gz")
-# The website doesn't provide the checksum atm, so we hard code it in the PKGBUILD for the time being
sha256sums=($(curl -s "https://download.jetbrains.com/python/pycharm-community-$_filever.tar.gz.sha256" | cut -d' ' -f1))
prepare() {
if [ -d "pycharm-community-$_pkgver" ]; then
- mv "pycharm-community-$_pkgver" "pycharm-community-$_buildver"
+ mv pycharm-community-{"$_pkgver","$_buildver"}
fi
- cat >"$pkgname.desktop" <<-EOF
- [Desktop Entry]
- Version="$pkgver"
- Type=Application
- Name=PyCharm Community EAP
- Exec="/opt/$pkgname/bin/pycharm.sh" %f
- Icon=pycharm
- Comment="$pkgdesc"
- Categories=Development;IDE;
- Terminal=false
- StartupNotify=true
- StartupWMClass=jetbrains-pycharm-ce
- EOF
}
build() {
cd "pycharm-community-$_buildver/plugins/python-ce/helpers/pydev/"
- # use absolute paths to the python executables so that users with an activated
- # virtual environment (like e.g. anaconda) can build without issues
- /usr/bin/python2 ./setup_cython.py build_ext --inplace
+ # using absolute paths to the python executables so that users with an activated virtual env
+ # (like e.g. anaconda) can build without issues
/usr/bin/python3 ./setup_cython.py build_ext --inplace
+ if pacman -Qq python2-setuptools &>/dev/null; then
+ /usr/bin/python2 ./setup_cython.py build_ext --inplace
+ fi
}
package() {
install -dm755 "$pkgdir"/{opt,usr/{bin,share/pixmaps}}
cp -R "pycharm-community-$_buildver" "$pkgdir/opt/$pkgname"
- install -Dm755 "$pkgname.desktop" -t"$pkgdir/usr/share/applications/"
+ install -Dm755 /dev/stdin "$pkgdir/usr/share/applications/$pkgname.desktop" <<-EOF
+ [Desktop Entry]
+ Version="$pkgver"
+ Type=Application
+ Name=PyCharm Community EAP
+ Exec="/opt/$pkgname/bin/pycharm.sh" %f
+ Icon=pycharm
+ Comment="$pkgdesc"
+ Categories=Development;IDE;
+ Terminal=false
+ StartupNotify=true
+ StartupWMClass=jetbrains-pycharm-ce
+ EOF
ln -s "/opt/$pkgname/bin/pycharm.sh" "$pkgdir/usr/bin/pycharm-ce"
ln -s "/opt/$pkgname/bin/pycharm.png" "$pkgdir/usr/share/pixmaps/"