summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndré Klitzing2022-05-30 09:55:28 +0200
committerAndré Klitzing2022-05-30 09:55:28 +0200
commit37c62c206076506b98addca961a7df0bd4660cb8 (patch)
treedeb84d37dac0120c3c87957edb79c2138aefb540 /PKGBUILD
downloadaur-37c62c206076506b98addca961a7df0bd4660cb8.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd9e4c91703f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=pydiffx
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Python Reader/Writer for DiffX Files"
+arch=('any')
+url="https://diffx.org/pydiffx/"
+license=('custom:MIT')
+makedepends=(python-build python-installer python-wheel)
+depends=(python python-setuptools)
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+sha256sums=('853216435008c23a0e2cd2c2a8ed15108bca449d6c31bc59d2e894246aff6bfa')
+
+build() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+
+# vim: set ts=2 sw=2 et: