summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Regan2015-06-12 09:06:11 -0500
committerJohn Regan2015-06-12 09:08:52 -0500
commit2aa2218f4366d28ad9f4f8c4c8609de81334a6d4 (patch)
tree1bf342c8b0a5ed2c19127e7ad2373e77eb226c96 /PKGBUILD
downloadaur-pydio-sync-git.tar.gz
updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..056eefbc8e8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: John Regan <john@jrjrtech.com>
+
+pkgname=pydio-sync-git
+pkgrel=1
+pkgver=r504.dd770f8
+pkgdesc="Pydio Sync Client"
+arch=('any')
+url="http://pyd.io"
+license=('GPL3')
+depends=(
+ 'python2-pyzmq'
+ 'python2-appdirs'
+ 'python2-xmltodict'
+ 'python2-yaml'
+ 'python2-argh'
+ 'python2-keyring'
+ 'python2-pathlib'
+ 'python2-pathtools'
+ 'python2-pydispatcher'
+ 'python2-aniso8601'
+ 'python2-requests'
+ 'python2-watchdog'
+ 'python2-cffi'
+ 'python2-flask'
+ 'python2-flask-restful'
+ 'python2-six'
+ 'python2-pytz'
+ )
+# TODO
+# python2-pytz is actually a req of python2-flask-restful
+# python2-aniso8601 is a req of python2-flask-restful
+makedepends=('git'
+ 'python2-setuptools')
+provides=('pydio-sync')
+conflicts=('pydio-sync')
+source=('git://github.com/pydio/pydio-sync.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/pydio-sync"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/pydio-sync"
+ # this isn't god-damn nodejs
+ sed -i 's/==/>=/' requirements.txt
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/pydio-sync"
+ python2 setup.py install --root=${pkgdir} --optimize=1
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}