summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfunilrys2020-02-02 22:06:02 +0100
committerfunilrys2020-02-02 22:06:02 +0100
commit8609b4d3e7eb8f2aa189d7ad193c2ac2630ed425 (patch)
tree173f665513f9d7c69737a4575d4c2c4f57947fd0 /PKGBUILD
parent0a1b8db43d943906fc88c169e1134a385a4debd6 (diff)
downloadaur-8609b4d3e7eb8f2aa189d7ad193c2ac2630ed425.tar.gz
Update PyFunceble to v3.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1d1329c34a0..5b94daea684f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,36 @@ _appName="pyfunceble"
pkgname=${_appName}
_name=${pkgname}
upstreamName="PyFunceble"
-pkgver=2.2.0
-pkgrel=3
-pkgdesc="The tool to check the availability or syntax of domains, IPv4 or URL."
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="The tool to check the availability or syntax of domains, IPv4, IPv6 or URL."
arch=('any')
url="https://funilrys.github.io/PyFunceble/"
license=('MIT')
conflicts=('pyfunceble-dev')
provides=("pyfunceble=${pkgver}")
depends=(
- 'python3'
- 'python-distribute'
- 'python-setuptools'
+ 'domain2idna'
+ 'python-box'
'python-colorama'
+ 'python-cryptography'
+ 'python-distribute'
+ 'python-dnspython'
+ 'python-dotenv'
'python-pyaml'
- 'python-urllib3'
+ 'python-pymysql'
'python-requests'
- 'domain2idna'
+ 'python-setuptools'
+ 'python-urllib3'
+ 'python3'
)
source=(
"https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${upstreamName}-${pkgver}.tar.gz"
"https://raw.githubusercontent.com/funilrys/PyFunceble/master/LICENSE"
)
sha256sums=(
- "0723af172bb6ec6a6e7197b5dc1285360e5edeef93f1d621078e62058501200b"
- "f03d3823524595a13999f7f0805b4189805e60a620175dc71e89ead03495c49f"
+ "69a78960edb9dafb10ad74eb63aba821dd6468cdf4777ccb7849633f2642984a"
+ "a11e4be5b3b09e157217214008e7f0e23092d26adb03ad593e51cffe18361508"
)
build() {