summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2024-04-23 16:58:13 -0300
committerRafael Fontenelle2024-04-23 16:58:13 -0300
commit598493ca7a9c333eb9ee6c7ab7f1f95442c9b9d8 (patch)
tree6e29ad1015ec0a62dd65a778d8e7f5601435878b /PKGBUILD
parente5172d64023f5883b1f2ef8c8601f0468a1f93b0 (diff)
downloadaur-598493ca7a9c333eb9ee6c7ab7f1f95442c9b9d8.tar.gz
Update to 0.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5842a503dd6f..46f3370b72f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=pyg3t
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.6.0
+pkgrel=1
pkgdesc="Python gettext Translation Toolkit"
arch=(any)
-url="https://github.com/pyg3t/pyg3t"
-license=('GPL3')
-depends=('python')
-checkdepends=('python-pytest')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('45bcdd4c8ee01491cc66f3e42c632245e9572e7fd1f2ae184fa1839db3e809ba')
+url="https://gitlab.com/pyg3t/pyg3t"
+license=(GPL-3.0-or-later)
+depends=(python)
+makedepends=(python-setuptools python-build python-installer python-wheel)
+checkdepends=(python-pytest)
+source=("$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('f2eaf64efe844688162ab4497a587ca794f426d51217e4dbb48fdc87caa67546')
build() {
cd $pkgname-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
+# Workaround for the tests requiring installed scripts (poselect, etc.)
check() {
cd $pkgname-$pkgver
- py.test -vv .
+ python -m installer --destdir='tmp_dir' dist/*.whl
+ export PATH="$PWD/tmp_dir/usr/bin:$PATH"
+ PYTHONPATH=$PWD python -m pytest -vv
}
package() {
cd $pkgname-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}