summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2024-04-23 16:05:18 -0300
committerRafael Fontenelle2024-04-23 16:05:18 -0300
commit18feff76097ff9504c353b484623c537ec06a02e (patch)
tree5eaded02fc1efebe87121d1f6da14a0b96ec05a6 /PKGBUILD
parent54d419babd8dafa9c840c8d5b0ffd7a985ad9746 (diff)
downloadaur-18feff76097ff9504c353b484623c537ec06a02e.tar.gz
Use SPDX license and apply PEP571
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7803dc5bf762..b27031a09512 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_name=pyg3t
pkgname=$_name-git
-pkgver=0.5.1.r335.c6ee292
+pkgver=0.5.1.r401.3939d89
pkgrel=1
pkgdesc="Python GetText Translation Toolkit"
arch=(any)
url="https://gitlab.com/pyg3t/pyg3t"
-license=('GPL3')
-depends=('python-dateutil')
-makedepends=('git' 'python-setuptools')
+license=(GPL-3.0-or-later)
+depends=(python)
+makedepends=(git python-setuptools python-build python-installer python-wheel)
provides=($_name)
conflicts=($_name)
source=(git+${url}.git)
@@ -24,11 +24,11 @@ pkgver() {
}
build() {
- cd "$srcdir/$_name"
- python setup.py build
+ cd $_name
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/$_name"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd $_name
+ python -m installer --destdir="$pkgdir" dist/*.whl
}