summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-04-29 15:25:55 +0200
committerBenjamin Chrétien2016-04-29 15:25:55 +0200
commit1fc0f9c700c7af16839a98aa96694d6b5c8d54dc (patch)
treea12bf8fecd1ee8c5f162e2ed9159a12f8f8ddb20 /PKGBUILD
parent22e079ca43399c8458849d9fe1e27fc4724fb50b (diff)
downloadaur-1fc0f9c700c7af16839a98aa96694d6b5c8d54dc.tar.gz
Update to version 1.7.4 (pkgrel 1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfeaa0f65178..ee5008d3b450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
# Contributor: zarra <zarraxx@gmail.com>
pkgname=pygccxml
-pkgver=1.0.0
-pkgrel=4
-pkgdesc="The purpose of pygccxml is to read a generated file and provide a simple framework to navigate C++ declarations, using Python classes."
+pkgver=1.7.4
+pkgrel=1
+pkgdesc="Simple framework to navigate C++ declarations, using Python classes."
arch=('i686' 'x86_64')
-url="http://www.sourceforge.net/projects/pygccxml"
+url="https://github.com/gccxml/pygccxml"
license=('custom')
depends=('gccxml-git' 'python2')
options=(!strip)
-source=(http://jaist.dl.sourceforge.net/sourceforge/pygccxml/pygccxml-${pkgver}.zip)
-md5sums=('44badbf8c4bcd3095290a90f2f2a9234')
+source=("https://github.com/gccxml/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('5f5ea231e2661b99588ac5cd413d1be11684bb8601b8df1483078d2f64a3ee25')
build() {
- cd "$srcdir/pygccxml-${pkgver}"
-
+ cd "${srcdir}/pygccxml-${pkgver}"
python2 setup.py build
}
package() {
- cd "$srcdir/pygccxml-${pkgver}"
-
+ cd "${srcdir}/pygccxml-${pkgver}"
python2 setup.py install --prefix=/usr --root=$pkgdir
}