summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2013-06-06 22:17:20 +0900
committerBenjamin Chrétien2013-06-06 22:21:23 +0900
commite6bc1c531f9273f85d41f9b9187ab4c09748e68d (patch)
treead3ee637608254274f5beb184eacacefbf62e917 /PKGBUILD
parent5e85f30d5130928b7bb70231e45bf54a474d4fa8 (diff)
downloadaur-e6bc1c531f9273f85d41f9b9187ab4c09748e68d.tar.gz
Fix pygccxml PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf6aa3b3e037..4b7090075406 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Contributor: zarra <zarraxx@gmail.com>
pkgname=pygccxml
pkgver=1.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="The purpose of pygccxml is to read a generated file and provide a simple framework to navigate C++ declarations, using Python classes."
arch=('i686' 'x86_64')
-url="http://www.language-binding.net/pygccxml/pygccxml.html"
+url="http://www.sourceforge.net/projects/pygccxml"
license=('custom')
-depends=('gccxml-cvs' 'python2')
+depends=('gccxml-git' 'python2')
options=(!strip)
source=(http://jaist.dl.sourceforge.net/sourceforge/pygccxml/pygccxml-${pkgver}.zip)
-
md5sums=('44badbf8c4bcd3095290a90f2f2a9234')
-
build() {
cd "$srcdir/pygccxml-${pkgver}"
- python2 setup.py build || return 1
- python2 setup.py install --prefix=/usr --root=$startdir/pkg
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/pygccxml-${pkgver}"
+ python2 setup.py install --prefix=/usr --root=$pkgdir
}
# vim:set ts=2 sw=2 et: