summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Granger2022-04-03 12:43:07 +0200
committerNicolas Granger2022-04-03 12:43:07 +0200
commite15fa8f77460804e79136929f85ce5b74937aac6 (patch)
tree3320b6596a4d14f73c187587b2659b33daf2ddda /PKGBUILD
downloadaur-e15fa8f77460804e79136929f85ce5b74937aac6.tar.gz
initial commit -> 1.5.36
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0881a4834348
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nicolas Granger <nicolas.granger@gmail.com>
+
+pkgname=pyghmi
+pkgver=1.5.36
+pkgrel=1
+pkgdesc="Python General Hardware Management Initiative (IPMI and others)"
+arch=('any')
+url="https://opendev.org/x/pyghmi"
+license=('Apache')
+depends=()
+makedepends=('python-setuptools' 'python-wheel' 'python-pip' 'python-pbr')
+source=("git+https://opendev.org/x/pyghmi#tag=${pkgver}")
+sha256sums=('SKIP')
+
+package() {
+ cd pyghmi
+
+ python setup.py install --root="$pkgdir" --optimize=1
+}