summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFranck STAUFFER2020-08-15 17:34:55 +0200
committerFranck STAUFFER2020-08-15 17:34:55 +0200
commit893a4541902e78360b5a630b16b53f584d78970b (patch)
treef33cc662b91eab6d437cea5c2610e19239738a5b /PKGBUILD
parentab568079eccb687882646441746ceeb9b48a5253 (diff)
downloadaur-893a4541902e78360b5a630b16b53f584d78970b.tar.gz
Update dependencies (and checksums in the .SRCINFO)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 087c5d24efd5..6b766e10cd35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,17 @@ pkgdesc="Python open source alternative to IDM (Internet Download Manager)"
arch=('any')
url="https://github.com/pyIDM/PyIDM"
license=('LGPL3')
-depends=('python>=3.6'
- 'python-pysimplegui>=4.18'
- 'python-pyperclip'
- 'python-plyer'
+depends=('ffmpeg'
+ 'python>=3.6'
'python-certifi'
- 'youtube-dl'
- 'python-pycurl'
'python-pillow'
- 'ffmpeg')
-makedepends=('python-setuptools' 'python-pip')
+ 'python-plyer'
+ 'python-pycurl'
+ 'python-pyperclip'
+ 'python-pysimplegui>=4.18'
+ 'python-pystray'
+ 'youtube-dl')
+makedepends=('python-setuptools')
changelog=$pkgname.changelog
source=("$pkgname-$pkgver.tar.gz::https://github.com/pyIDM/PyIDM/archive/$pkgver.tar.gz"
"no_update.patch")
@@ -37,9 +38,6 @@ build() {
package() {
cd "$srcdir/PyIDM-$pkgver"
- # python-pystray does not work in AUR
- pip install pystray
-
python setup.py install --root="$pkgdir" --skip-build --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}