summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStrit2016-07-11 08:44:32 +0200
committerStrit2016-07-11 08:44:32 +0200
commitab6ba15e45ee3a7beb37d0458f734b22023af8bb (patch)
tree0caf70c0c1fed691299828cadc733b667ca1d895 /PKGBUILD
downloadaur-pykaraoke.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80bd2f68293a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: SpepS <dreamspepser at yahoo dot it>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+
+pkgname=pykaraoke
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="A free karaoke player for Linux, FreeBSD, Windows and GP2X."
+arch=('i686' 'x86_64')
+url="http://www.kibosh.org/pykaraoke/index.php"
+license=('LGPL')
+depends=('python2-pygame' 'python2-numpy' 'wxpython' 'desktop-file-utils')
+optdepends=('timidity++: Midi Support')
+#install="$pkgname.install"
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.zip")
+md5sums=('0a18dc2c4b2b56ee81987fac81d3f011')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 setup.py install --prefix=/usr --root="$pkgdir/"
+
+ # python2 fix
+ sed -i "s|env python|&2|" `grep -rl "env python" "$pkgdir"`
+}