summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Wojdyła2023-10-22 02:24:34 +0200
committerMichał Wojdyła2023-10-22 02:24:34 +0200
commit69a6318ac1849663cec1d19459fba2f308697e71 (patch)
tree5fc07db43b35e9ab1cb77b7e888a7d3c66570476 /PKGBUILD
parentd7d4009069a4ab32968ad3e08944955f15e8afcd (diff)
downloadaur-69a6318ac1849663cec1d19459fba2f308697e71.tar.gz
update to 0.5.0b3.dev74
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ea6a4da717e..a1c12e8b5dd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
pkgname='pyload-ng'
-pkgver=0.5.0b3.dev73
+pkgver=0.5.0b3.dev74
pkgrel=1
pkgdesc="The free and open-source Download Manager written in pure Python"
url="https://pyload.net/"
license=('AGPL3')
arch=('any')
depends=('python-semver' 'python-pycurl' 'python-js2py' 'python-filetype' 'python-cryptography' 'python-bitmath'
- 'python-flask-themes2' 'python-flask-session' 'python-flask-compress' 'python-flask-caching' 'python-flask-babel'
+ 'python-flask-themes2' 'python-flask-session2' 'python-flask-compress' 'python-flask-caching' 'python-flask-babel'
'python-cheroot' 'python-setuptools' 'python-certifi')
optdepends=('caffeine: For AntiStandby plugin'
'python-beautifulsoup4: for XFileSharing plugin'
'python-slixmpp: for XMPP plugin'
'python-pillow: for some CAPTCHA stuff'
'python-beaker: for some accounts') # <-- honestly I have no idea for which accounts but I saw there were some imports that needed beaker modules in code.
-source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-$pkgver.tar.gz" "patch.patch")
-sha256sums=('50300ee48730e65551a220b5f3755f67070bb6060b507864e9e1ccc7c0a4a9fc' '37aa269f69c2114b3fbb8992f564a812639b2a7a228150f840ccbaad1985a59b')
+source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-$pkgver.tar.gz")
+sha256sums=('55904c9e4a4932f3f923ce336f31a223c3014224db9e923a69c8327a1e099115')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
- # quick fix so that it doesn't need flask 2.3.0
- patch -p0 -i ../patch.patch
# Allow higher library versions
sed -e 's/~=/>=/g' -i setup.cfg
}