summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Wienke2018-05-28 11:56:43 +0200
committerJohannes Wienke2018-05-28 11:56:43 +0200
commitc7d467891aed41e92c4724e9f1c17df576b78601 (patch)
treedcdfe332ba45bb04d3f19ec8490131fcef87f05e /PKGBUILD
parent6705982f8506cade2debb6de6841bcd17e9ae25a (diff)
downloadaur-c7d467891aed41e92c4724e9f1c17df576b78601.tar.gz
Fix launching
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ece16c4ff338..58a62eb0884c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Johannes Wienke <languitar@semipol.de>
pkgname=pyls-mypy
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="A Mypy plugin for the python language server"
url="https://github.com/tomv564/pyls-mypy"
depends=('python' 'python-language-server' 'mypy' 'python-future')
@@ -12,6 +12,12 @@ arch=('any')
source=("git+https://github.com/tomv564/pyls-mypy.git#tag=${pkgver}")
sha256sums=('SKIP')
+prepare() {
+ cd "${srcdir}/pyls-mypy"
+ # this is included in standard python and prevents the server from launching
+ sed -i "/configparser/d" setup.py
+}
+
package() {
cd "${srcdir}/pyls-mypy"
python setup.py install --root="$pkgdir" -v --optimize=1