summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-05-04 10:04:26 -0600
committerMark Wagie2022-05-04 10:04:26 -0600
commit253343ddb92bda9f4a4d3a763a3fb3d5f0ab8762 (patch)
treede044fd20bcbb800fcc910fc1182ff659cadb210 /PKGBUILD
parent85b035c4b063f89d9f452906292e35ef4e3a62bf (diff)
downloadaur-253343ddb92bda9f4a4d3a763a3fb3d5f0ab8762.tar.gz
9.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be1ff6a1730b..a583e82d0c88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,38 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Duru Can Celasun <can at dcc dot im>
pkgname=pymdown-extensions
-pkgver=9.3
+_name=pymdown_extensions
+pkgver=9.4
pkgrel=1
pkgdesc="Extensions for Python Markdown"
arch=('any')
url="https://facelessuser.github.io/pymdown-extensions"
license=('MIT')
depends=('python-markdown')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-optdepends=('python-pygments: syntax highlighting')
-checkdepends=('python-pyaml' 'python-pygments' 'python-pytest-cov')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+makedepends=('python-build' 'python-editables' 'python-hatchling' 'python-installer' 'python-packaging>=21.3' 'python-wheel')
+optdepends=('python-pygments>=2.12: syntax highlighting')
+checkdepends=('python-pyaml' 'python-pygments>=2.12' 'python-pytest-cov')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$_name-$pkgver.tar.gz")
#source=("$pkgname-$pkgver.tar.gz::https://github.com/facelessuser/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('a80553b243d3ed2d6c27723bcd64ca9887e560e6f4808baa96f36e93061eaf90')
+sha256sums=('1baa22a60550f731630474cad28feb0405c8101f1a7ddc3ec0ed86ee510bcc43')
build() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
python -m build --wheel --no-isolation
}
check() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
python run_tests.py
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$_name-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
# symlink license to proper directory
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
install -d "$pkgdir/usr/share/licenses/$pkgname"
- ln -s "${site_packages}/pymdown_extensions-$pkgver.dist-info/LICENSE.md" \
+ ln -s "${site_packages}/$_name-$pkgver.dist-info/LICENSE.md" \
"$pkgdir/usr/share/licenses/$pkgname/"
}