summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-01-25 19:19:28 -0700
committerMark Wagie2021-01-25 19:19:28 -0700
commit8c88ef76811c910a5482da024d1759c598251c8d (patch)
tree71bf72b195bff6f5f26e7bf0f83332caef1babf2 /PKGBUILD
parent9f5ab36db03ab702467f044db5145ed4786d27ee (diff)
downloadaur-8c88ef76811c910a5482da024d1759c598251c8d.tar.gz
8.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcaeaae9c67f..753b82576aa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Duru Can Celasun <can at dcc dot im>
pkgname=pymdown-extensions
-pkgver=8.1
+pkgver=8.1.1
pkgrel=1
pkgdesc="Extensions for Python Markdown"
arch=('any')
-url="http://facelessuser.github.io/pymdown-extensions"
+url="https://facelessuser.github.io/pymdown-extensions"
license=('MIT')
depends=('python-markdown')
makedepends=('python-setuptools')
optdepends=('python-pygments: syntax highlighting')
+checkdepends=('python-pyaml' 'python-pytest-cov')
source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
#source=("$pkgname-$pkgver.tar.gz::https://github.com/facelessuser/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('565583c5964ac8253896ef4a7f14023075503ca6514d7d470b343290b96fc6da')
+sha256sums=('632371fa3bf1b21a0e3f4063010da59b41db049f261f4c0b0872069a9b6d1735')
build() {
cd "$pkgname-$pkgver"
python setup.py build
}
+check() {
+ cd "$pkgname-$pkgver"
+ python run_tests.py
+}
+
package() {
cd "$pkgname-$pkgver"
export PYTHONHASHSEED=0