summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-03-19 11:03:04 -0600
committerMark Wagie2022-03-19 11:03:04 -0600
commitae8bc0d201bae3e403f92fba1dd66ec95710d13b (patch)
tree4f8e27df9a5294eae7635f82d6dee4de1009e8ee /PKGBUILD
parent2e824a02c665d3217dce557526eeab37444ea11b (diff)
downloadaur-ae8bc0d201bae3e403f92fba1dd66ec95710d13b.tar.gz
9.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af91f394eb33..2f4ad2165cc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Duru Can Celasun <can at dcc dot im>
pkgname=pymdown-extensions
-pkgver=9.2
-pkgrel=2
+pkgver=9.3
+pkgrel=1
pkgdesc="Extensions for Python Markdown"
arch=('any')
url="https://facelessuser.github.io/pymdown-extensions"
@@ -13,7 +13,7 @@ optdepends=('python-pygments: syntax highlighting')
checkdepends=('python-pyaml' 'python-pygments' 'python-pytest-cov')
source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz")
#source=("$pkgname-$pkgver.tar.gz::https://github.com/facelessuser/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('ed8f69a18bc158f00cbf03abc536b88b6e541b7e699156501e767c48f81d8850')
+sha256sums=('a80553b243d3ed2d6c27723bcd64ca9887e560e6f4808baa96f36e93061eaf90')
build() {
cd "$pkgname-$pkgver"
@@ -29,9 +29,9 @@ package() {
cd "$pkgname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
- # Move license to proper directory
+ # symlink license to proper directory
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
install -d "$pkgdir/usr/share/licenses/$pkgname"
- mv "${pkgdir}${site_packages}/pymdown_extensions-$pkgver.dist-info/LICENSE.md" \
+ ln -s "${site_packages}/pymdown_extensions-$pkgver.dist-info/LICENSE.md" \
"$pkgdir/usr/share/licenses/$pkgname/"
}