summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiguel Revilla2015-07-02 16:55:09 +0200
committerMiguel Revilla2015-07-02 16:55:09 +0200
commita5274f2276598269b458d63a333a3439d43316b8 (patch)
tree4d6f87411044ca5968aeec8f717d6497d8f7f89b /PKGBUILD
downloadaur-a5274f2276598269b458d63a333a3439d43316b8.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65a42fa8252d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer: Jarek Sedlacek <jareksedlacek@gmail.com
+
+pkgname=pymetar
+pkgver=0.19
+pkgrel=1
+pkgdesc="downloads the weather report for a given station ID, decodes it and the provides easy access to all the data found in the report"
+arch=('i686' 'x86_64')
+url="http://www.schwarzvogel.de/software-pymetar.shtml"
+license=('GPL2')
+depends=('python2>=2.7' )
+source=("http://www.schwarzvogel.de/pkgs/$pkgname-$pkgver.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py build
+ sed -i 's/\/usr\/bin\/python -tt/\/usr\/bin\/env python2/' bin/pymetar
+}
+
+package(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -m0755 -d ${pkgdir}/usr/{bin,lib/python2.7/site-packages,share/${pkgname}}
+ chmod 0755 ${pkgdir}/usr/bin/
+ install -m0644 -D PKG-INFO ${pkgdir}/usr/lib/python2.7/site-packages/${pkgname}-${pkgver}-py2.6.egg-info
+ install -m0644 -D build/lib/pymetar.py ${pkgdir}/usr/lib/python2.7/site-packages/
+ install -m0644 -D README librarydoc.txt ${pkgdir}/usr/share/${pkgname}
+ install -m0755 -D bin/pymetar $pkgdir/usr/bin/
+
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('c1eb3afb5f55c414ffda4cdbb561928d')