summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthijs Tadema2024-03-12 11:09:39 +0100
committerMatthijs Tadema2024-03-12 11:10:10 +0100
commit83b557e5344d8521f8a27553b037d13c499d1d29 (patch)
tree91d7fdca6bfb8be33b0e3cf549c33b6e05cf1ba2 /PKGBUILD
parente2e0009f87751bd880d8ed54626117e756edba56 (diff)
downloadaur-83b557e5344d8521f8a27553b037d13c499d1d29.tar.gz
Include patch to enable glm experimental features
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e603e9a3ca3f..d41194f6bdeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,9 +31,11 @@ optdepends=('python-pyqt5: Qt5 based UI')
conflicts=('pymol')
provides=("${_name}=${pkgver}")
source=(${_name}::"git+https://github.com/schrodinger/pymol-open-source.git"
- ${_name}.png::"https://c.fsdn.com/allura/p/pymol/icon")
+ ${_name}.png::"https://c.fsdn.com/allura/p/pymol/icon"
+ "glm_exp.patch")
md5sums=('SKIP'
- 'a6b62ae41658a772f75b3b123a8e5c0b')
+ 'a6b62ae41658a772f75b3b123a8e5c0b'
+ '26b4244b871a55a83bc6f42d761bc6f9')
pkgver() {
cd "${srcdir}/${_name}"
@@ -41,6 +43,9 @@ pkgver() {
}
prepare() {
+ # Apply patch
+ patch --directory="${_name}" --forward --strip=1 --input=../glm_exp.patch
+
# create desktop file
gendesk -f -n \
--pkgname "${_name}" \