summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2017-02-21 16:07:10 +0700
committerKonstantin Shalygin2017-02-21 16:07:15 +0700
commit43d30a13469581ad9e8793919e99cb4088ffc016 (patch)
tree48c47c7a938df54da12df65f0752779116fa14a1 /PKGBUILD
downloadaur-43d30a13469581ad9e8793919e99cb4088ffc016.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f35aa6037c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Konstantin Shalygin <k0ste@k0ste.ru>
+# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
+
+pkgbase='pyocclient'
+pkgname=('python-pyocclient' 'python2-pyocclient')
+pkgver='0.4'
+pkgrel='1'
+pkgdesc='Python client library for ownCloud'
+arch=('any')
+url="https://github.com/owncloud/${pkgbase}"
+makedepends=('python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+license=('MIT')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('841c9057b66fc56ffa867b6b94ee9ec175ddd70ca9c80e0c5e4c51a1694c51dc')
+
+package_python-pyocclient() {
+ depends=('python' 'python-requests' 'python-six')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py install -O1 --root="${pkgdir}"
+}
+
+package_python2-pyocclient() {
+ depends=('python2' 'python2-requests' 'python2-six')
+
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python2 setup.py install -O1 --root="${pkgdir}"
+}